poj 2002 Squares


poj 2002 Squares
Squares
Time Limit: 3500MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

[Submit]   [Go Back]   [Status]

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

[Submit]   [Go Back]   [Status]

题意:给你若干个点,让你找出这些点可以组成正方形的个数。

分析:如果暴力的话时间复杂度为O(n^4)肯定会 TLE  ,这里使用了hash查找。不过也有二分做的。。

Source Code

Problem: M   User: sdau_09_zys
Memory: 1352 KB   Time: 969 MS
Language: G++   Result: Accepted
Public:  

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
using namespace std;

struct Point
{
    int x,y;
}p[1001];

const int size=22000;
/**
  * hash表为啥要开到22000?
  * 题目中给的两点的距离小于20000,
  * 到原点的距离完全可能大于20000,
  * 这里有猜测的意味。
***/

struct Node
{
    Node():next(0){}//对next初始化
    int x,y;
    Node * next;
}hash[size];//拉链法的hash表

bool findPoint(int x,int y)
{
    int key=(x*x+y*y)%size;
    Node *pt=&hash[key];
    while(pt->next)
    {
        if(pt->next->x==x&&pt->next->y==y)return true;
        pt=pt->next;
    }
    return false;
}
int main()
{
    int n,i,j,key,x,y,x1,y1,x2,y2,ans;
    Node* tem;
    Node* pt;
    while(scanf("%d",&n),n)
    {
        ans=0;
        memset(hash,0,sizeof hash);
        for(i=0;i<n;i++)
        {
            scanf("%d %d",&p[i].x,&p[i].y);
            tem=new Node;
            tem->x=p[i].x;tem->y=p[i].y;

            key=(p[i].x*p[i].x+p[i].y*p[i].y)%size;
            //用到原点的距离作为hash函数

            pt=&hash[key];
            while(pt->next)
            {
                pt=pt->next;
            }
            pt->next=tem;
        }
        for(i=0;i<n-1;i++)
        {
            for(j=i+1;j<n;j++)
            {
                x=p[i].x-p[j].x;
                y=p[i].y-p[j].y;

                //斜下方的正方形
                x1=p[i].x+y;
                y1=p[i].y-x;
                x2=p[j].x+y;
                y2=p[j].y-x;

                if(findPoint(x1,y1)&&findPoint(x2,y2))ans++;

                //斜上方的正方形
                x1=p[i].x-y;
                y1=p[i].y+x;
                x2=p[j].x-y;
                y2=p[j].y+x;

                if(findPoint(x1,y1)&&findPoint(x2,y2))ans++;
            }
        }
        printf("%d\n",ans>>2);//为啥要除以4呢?是因为正方形的4个边都会被枚举一次
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值