POJ2002 Squares

原题链接:http://poj.org/problem?id=2002
博主的中文题面:
https://www.luogu.org/problemnew/show/T23926

Squares

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

题目大意

给一堆点,求能构成多少正方形

题解

n个点可以构成n^2/2条边,对于每一条边,都可以查找对应的可以构成正方形边,这个过程可以二分查找,也可以用哈希,因为每个正方形会被两组对边统计两次,所以需要除以二。

代码
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int M=1005;
struct pt{int x,y;};
bool operator == (const pt &a,const pt &b){return a.x==b.x&&a.y==b.y;}
bool operator < (const pt &a,const pt &b){return a.x!=b.x?a.x<b.x:a.y<b.y;}
pt p[M];
int n;
void in()
{
    for(int i=1;i<=n;++i)
    scanf("%d%d",&p[i].x,&p[i].y);
}
int find(int le,int ri,pt x)
{
    int mid=(le+ri)>>1;
    if(p[mid]==x) return mid;
    if(le==ri) return -1;
    if(p[mid]<x) return find(mid+1,ri,x);
    return find(le,mid,x);
}
void ac()
{
    long long ans=0;
    sort(p+1,p+1+n);
    pt f;
    for(int i=1;i<=n;++i)
    for(int j=i+1;j<=n;++j)
    {
        f.x=p[i].x-p[j].y+p[i].y;
        f.y=p[i].y+p[j].x-p[i].x;
        if(find(1,n,f)<0) continue;
        f.x=p[j].x-p[j].y+p[i].y;
        f.y=p[j].y+p[j].x-p[i].x;
        if(find(1,n,f)<0) continue;
        ans++;
    }
    printf("%lld\n",ans/2);
}
void reset()
{
    memset(p,0,sizeof(p));
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        reset();in();ac();
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ShadyPi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值