数据结构经典题目给定序列生成完全二叉搜索树

04-树6 Complete Binary Search Tree (30 point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

 

这个题目使用完全二叉树的数组表示方法,通过求完全二叉树左子数的个数,递归的建立完全二叉搜索树

 

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

const int N = 1010;
int T[N], A[N];

int GetLeftLength(int n) {

	int H = int(log2(n + 1));    // 树的高度
	int X = n + 1 - pow(2, H);   // 最后一层结点个数.
	int temp = pow(2, H - 1);    
	X = min(X, temp);            // 最后一层左子数的个数
	int L = pow(2, H - 1) - 1 + X;		// 左子树结点数
	return L;
}


void solve(int ALeft, int ARight, int TRoot) {
	
	int n = ARight - ALeft + 1;
	if (n == 0)
		return;
	int L = GetLeftLength(n);                   // 计算出n个结点的完全二叉树的左子数有多少个结点
	T[TRoot] = A[ALeft + L];
	int LeftTRoot = TRoot * 2 + 1;              // 左子数根节点
	int RightTRoot = TRoot * 2 + 2;             // 右子数根节点
	solve(ALeft, ALeft + L - 1, LeftTRoot);     // 递归的解决左边
	solve(ALeft + L + 1, ARight, RightTRoot);   // 递归的解决右边
}

int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> A[i];
	sort(A, A + n);
	solve(0, n - 1, 0);
	for (int i = 0; i < n; i++) {
		if (i == n - 1)
			cout << T[i] << endl;
		else
			cout << T[i] << " ";
	}
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值