问题 F: 24 Point game
时间限制: 3 Sec 内存限制: 64 MB[ 提交][ 状态][ 讨论版]
题目描述
There is a game which is called 24 Point game.
In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets.
e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested.
Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。
输入
The input has multicases and each case contains one line The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases. Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be. Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
# include<stdio.h>
# include<math.h>
# include<string.h>
int m,n,sum1,v[10];
double a[10];
bool dfs(double sum)
{
if(m==n&&fabs(sum-sum1)<0.0000001)//因为是double类型
{
return true;
}
for(int i=0;i<n;i++)
{
if(!v[i])
{ v[i]=1;
m++;
if(dfs(sum+a[i])) return true;//6种,其中减和除为两次
if(dfs(sum-a[i])) return true;
if(dfs(sum*a[i])) return true;
if(dfs(sum/a[i])) return true;
if(dfs(a[i]-sum)) return true;
if(dfs(a[i]/sum)) return true;
v[i]=0;
m--;
}
}
return false;
}
int main(){
int t;
scanf("%d",&t);
while(t--)
{ int k=0;
scanf("%d%d",&n,&sum1);
for(int i=0;i<n;i++)
{
scanf("%lf",&a[i]);
}
for(int i=0;i<n;i++)
{
memset(v,0,sizeof(v));
m=1;
v[i]=1;
if(dfs(a[i]))
{ k=1;
break;
}
}
if(k) printf("Yes\n");
else printf("No\n");
}
return 0;
}