1141 PAT Ranking of Institutions (25 分)
After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:
ID Score School
where ID
is a string of 6 characters with the first one representing the test level: B
stands for the basic level, A
the advanced level and T
the top level; Score
is an integer in [0, 100]; and School
is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID
is unique for each testee.
Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:
Rank School TWS Ns
where Rank
is the rank (start from 1) of the institution; School
is the institution code (all in lower case); ; TWS
is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5
, where ScoreX
is the total score of the testees belong to this institution on level X
; and Ns
is the total number of testees who belong to this institution.
The institutions are ranked according to their TWS
. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns
. If there is still a tie, they shall be printed in alphabetical order of their codes.
Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2
题意 :一个学校派出多支队伍进行比赛,队伍分为A、B、T三级,将每个学校的多支队伍所得的分数按照给定公式进行计算,输出学校的排名、名称、得分以及参加比赛的队伍数量,若学校得分相同,则按照参加比赛的队伍数量进行升序排列,若参加比赛的队伍数量相同则按照学校名称根据字典序排列。
我的答案只得了20分,未AC~~~~~~
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<unordered_map>
using namespace std;
struct node
{
string school;
int score;
int num;
node(){}
node(string school1,int score1,int num1):school(school1),score(score1),num(num1){}
friend bool operator <(node A, node B) {
if (A.score != B.score) return A.score > B.score;
else if (A.num != B.num) return A.num < B.num;
else if (A.school != B.school) return A.school <= B.school;
}
};
unordered_map<string, int>mp;
unordered_map<string, int>m;
int main()
{
int n;
cin >> n;
for (int i = 0;i < n;i++) {
string s1, s2;
int num;
cin >> s1 >> num >> s2;
for (int j = 0;s2[j];j++) {
s2[j] = tolower(s2[j]);
}
if (s1[0] == 'A') mp[s2] += num;
else if (s1[0] == 'B') mp[s2] += num / 1.5;
else if (s1[0] == 'T') mp[s2] += num * 1.5;
m[s2]++;
}
cout << mp.size() << endl;
vector<node>s;
for (unordered_map<string, int>::iterator it = mp.begin();it != mp.end();++it) {
s.push_back(node(it->first, mp[it->first], m[it->first]));
}
sort(s.begin(), s.end());
int flag = -1;
for (int i = 0;i < s.size();i++) {
if (flag == s[i].score) {
cout << i << " " << s[i].school << " " << s[i].score << " " << s[i].num << endl;
flag = -1;
}
else {
cout << i +1<< " " << s[i].school << " " << s[i].score << " " << s[i].num << endl;
flag = s[i].score;
}
}
return 0;
}