PAT甲级 1142

1142 Maximal Clique (25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题意:给定无向图的顶点以及无向边,后给出顶点序列判断其是否是最大的集合(不能通过一个以上的相邻顶点进行拓展)、是否是集合(每两个不同的顶点是相邻的),再按照给定格式进行输出即可。

#include <iostream>
#include<vector>
using namespace std;

int a[300][300];
int main()
{
    int m,nv,ne,ta,tb,k;
    cin>>nv>>ne;
    for(int i=0; i<ne; i++)
    {
        cin>>ta>>tb;
        a[ta][tb]=a[tb][ta]=1;
    }
    cin >>m;
    for(int i=0; i<m; i++)
    {
        cin>>k;
        vector<int> v(k);
        int ha[300]= {0};
        int isC=1,isM=1;
        for(int j=0; j<k; j++)
        {
            cin>>v[j];
            ha[v[j]]=1;
        }
        for(int j=0; j<k; j++)
        {
            if(isC==0)break;
            for(int t=j+1; t<k; t++)
            {
                if(a[v[j]][v[t]]==0)
                {
                    isC=0;
                    cout<<"Not a Clique"<<endl;
                    break;
                }
            }
        }
        if(isC==0)continue;
        for(int j=1; j<=nv; j++)
        {
            if(ha[j]==0)
            {
                for(int t=0; t<k; t++)
                {
                    if(a[v[k]][v[j]]==0)break;
                    if(t==k-1)isM=0;
                }
            }
            if(isM==0)cout<<"Not Maximal"<<endl;
            break;
        }

    if(isM==1)
        cout << "Yes" << endl;
}
return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值