PAT甲级 1134

1134 Vertex Cover (25 分)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

 题意 :给定结点数目n和边数m,后m行给出边的结点,之后一行给出结点序列数量k,之后k行给出结点数目和结点,问 给定的 图中的结点是否至少有一个出现在结点序列中,若是则输出Yes,否则输出No

解题思路:用vector v[n]保存某结点属于的某条边的编号。对于每一个集合做判断,遍历集合中的每一个元素,将当前元素能够属于的边的编号i对应的hash[i]标记为1,表示这条边是满足有一个结点出自集合S中的。最后判断hash数组中的每一个值是否都是1,如果有不是1的,说明这条边的两端结点没有一个出自集合S中。

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n,m,k,nv,a,b,num;
    cin>>n>>m;
    vector<int> v[n];
    for(int i=0; i<m; i++)
    {
        cin>>a>>b;
        //记录结点属于哪条边
        v[a].push_back(i);
        v[b].push_back(i);
    }
    cin>>k;
    for(int i=0; i<k; i++)
    {
        cin>>nv;
        int f=0;
        //将hash初始化为0
        vector<int> hash(m,0);
        for(int t=0; t<nv; t++)
        {
            cin>>num;
            //v[num].size()是记录num属于几条边
            for(int j=0; j<v[num].size(); j++)
            {
                //查看结点是否有属于的边
                hash[v[num][j]]=1;
            }
        }
        for(int i=0; i<m; i++)
        {
            if(hash[i]==0)
            {
                cout<<"No"<<endl;
                f=1;

                break;//不可少
            }


        }
        if(f==0)
            cout<<"Yes"<<endl;
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值