boj problem 1329 快速排序tle 堆排序还可以~~需要熟悉快速排序和堆排序~~静态数组全局下可以很大 但main下不行 具体看1331那篇

寻找相同Submit: 1738   Accepted:418Time Limit: 1000MS  Memory Limit: 65535K

Description
有一组数,很多很多个数,里面有一个数出现了超过一半次,请你把它找出来。

Input
先是一个N (N<=400000),然后接下来一行N个数,多组数据输入。

Output
对每个Case,输出一行,这一行只含有一个在之前数列中出现超过一半次的数。每个case之后输出一个空行。

Sample Input

11
5 5 5 5 5 5 1 2 3 4 6


Sample Output

Case 1: 5


Source

 

 

 

#include<iostream>
#include<stdio.h>
using namespace std;
void adjust(int *a,int k,int n);
void buildheap(int *a,int n)    //大顶堆
{
  for(int i=n/2;i>0;i--)
       adjust(a,i,n);
}
void adjust(int *a,int k,int n)
{
 int temp=a[k];
 for(int i=2*k;i<=n;i=i*2)
 {
   if(a[i]<a[i+1]&&i<n)
    i++;
   if(temp>=a[i])   //当时错在这里  是temp比较 不应该是a[k] 因为AK有变化~
    break;
   else
   {
     a[k]=a[i];
  k=i;
   }
 }
 a[k]=temp;
}
void heapsort(int *a,int n)
{
 int temp,i;
 buildheap(a,n);
 for(i=n;i>1;i--)
 {
   temp=a[1];
   a[1]=a[i];
   a[i]=temp;
   adjust(a,1,i-1);
 }
}
int main()
{
 int n,i,c=1,num;


 while(cin>>n)
 {
  int *a=new int[n+1];  //动态数组
   for(i=1;i<n+1;i++)
   { 
    cin>>a[i];
   }
   heapsort(a,n);
  // for(i=1;i<n+1;i++)
//    cout<<a[i];
   
   num=a[(n+1)/2];
   cout<<"Case "<<c<<": "<<num<<endl;
   cout<<endl;
   c++;
   delete[] a;
 }
 
 return 0;
}

 

 

   

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值