【HDU】2604 - Queuing(递推 & 思维 & 矩阵构造 & 快速幂)

19 篇文章 0 订阅
13 篇文章 0 订阅
博客探讨了HDU 2604 Queuing问题的解决策略,主要涉及递推公式推导和矩阵构造。通过分析,得出递推关系式f(n) = f(n - 1) + f(n - 3) + f(n - 4),并提及代码实现中矩阵构造的部分。
摘要由CSDN通过智能技术生成

点击打开题目

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4683    Accepted Submission(s): 2067


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10  6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 

Author
WhereIsHeroFrom
 

Source
 



这个题推递推公式又是个大麻烦了。

我们还是考虑最后一位,观察知道如果最后一位是m的话,前面就不用管了,这样的方案数为f(i - 1)。

然后是最后一位是 f 的情况,我们知道,最后一位是 f 时,前面两位只能是mmf、mff。

如果是mmf的话,前面是什么也不用管了,这种的方案数为f(i - 3)。

如果是mff,再前面是只能是m,所以它的方案数为f(i - 4)。


然后把上面的加起来就得到了递推公式:

f(n)= f(n - 1)+ f(n - 3)+ f(n - 4)


然后是矩阵的构造了,

如图:


(突然发现上面最后一个式子有误,后面的应该是(fn  fn-1  fn-2  fn-3))


代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 4
#define CLR(a,b) memset(a,b,sizeof(a))
int MOD;
struct Matrix
{
	__int64 m[MAX+5][MAX+5];
	int w,h;
}pr,res,ori;
void init()
{
	pr.w = pr.h = 4;		//构造4*4的矩阵
	CLR(pr.m,0);
	for (int i = 1 ; i <= 3 ; i++)
		pr.m[i][i+1] = pr.m[i][1] = 1;
	pr.m[4][1] = 1;
	pr.m[2][1] = 0;
	res.h = 4;		//构造单位矩阵
	res.w = 4;
	CLR(res.m,0);
	for (int i = 1 ; i <= 4 ; i++)
		res.m[i][i] = 1;
}
Matrix Matrix_multiply(Matrix x,Matrix y)
{
	Matrix t;
	t.h = x.h;
	t.w = y.w;
	CLR(t.m,0);
	for (int i = 1 ; i <= x.h ; i++)
	{
		for (int j = 1 ; j <= x.w ; j++)
		{
			if (x.m[i][j] == 0)
				continue;
			for (int k = 1 ; k <= y.w ; k++)
				t.m[i][k] = (t.m[i][k] + x.m[i][j] * y.m[j][k] % MOD) % MOD;
		}
	}
	return t;
}
void Matrix_mod(int n)		//矩阵快速幂 
{
	while (n)
	{
		if (n & 1)
			res = Matrix_multiply(res , pr);
		pr = Matrix_multiply(pr , pr);
		n >>= 1;
	}
}
int main()
{
	int n;
	ori.w = 4;
	ori.h = 1;
	ori.m[1][1] = 9;
	ori.m[1][2] = 6;
	ori.m[1][3] = 4;
	ori.m[1][4] = 2;
	while (~scanf ("%d %d",&n,&MOD))
	{
		if (n == 0)
		{
			printf ("0\n");
			continue;
		}
		else if (n <= 4)
		{
			printf ("%I64d\n",ori.m[1][5-n] % MOD);
			continue;
		}
		init();
		Matrix_mod(n - 4);
		res = Matrix_multiply(ori , res);		//要注意矩阵乘法没有交换律
		printf ("%I64d\n",res.m[1][1]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值