YTU 3259: 2.字符串处理

3259: 2.字符串处理


Description

字符串处理,输出字符串不重复字符的数目。

Input

输入字符串(字符总数小于50

Output

不相同字符的个数

Sample Input

abca

Sample Output

3

#include<stdio.h>
#include<string.h>
int main()
{
    int s[999]={0};
    int i,j,k,n=0;
    char ch[99];
    gets(ch);
    int t=strlen(ch);
    for(i=0;i<t;i++)
    {
        if(s[ch[i]]==0)
        {
            n++;
            s[ch[i]]++;
        }
    }
    printf("%d",n);
    return 0;
}

Another solution.

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,cnt=0,t;
    char ch[99];
    gets(ch);
    t=strlen(ch);
    for(i=0;i<t;i++)
    {
        for(j=0;j<=i;j++)
            if(ch[i]==ch[j])
                break;
        if(i==j)
            cnt++;
    }
    printf("%d\n",cnt);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值