POJ 3126 Prime Path

Prime Path

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

Northwestern Europe 2006

 

题目大意 

输入 两个四位素数 算 从n到m最少需要几步 

要求 每一步只能有一位不同 且同为素数

 

中间因为 p变量 全局又局部定义浪费我 0.5h ?

石锤bfs 看数据量直接爆就行

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <queue>
using namespace std;

int a[10010];
int prime[10010];
int b[10010];
int vis[10010];

typedef struct node{
	int value;
	int step;
}Node;

bool judge(int n,int m)
{
	int sum = 0;
	int t1,t2;
	while(n!=0){
		t1 = n%10;
		t2 = m%10;
		if(t1!=t2){
			sum++;
		}
		n/=10;
		m/=10;
	}
	if(sum==1){
		return true;
	}
	return false;
}

int p = 0;
int ans = 0;
bool bfs(int n, int m)
{
	memset(vis,0,sizeof(vis));
	Node start;
	start.value = n;
	start.step = 0;
	queue<Node> q;
	q.push(start);
	vis[n] = 1;
	while(!q.empty()){
		Node t;
		t = q.front();
		q.pop();
		if(t.value==m){
			ans = t.step;
			return true;
		}
		//cout<<p<<endl;
		//cout<<vis[1073]<<endl;
		for(int i=0;i<p;i++){
			if(!vis[prime[i]]&&judge(prime[i],t.value)){
				Node next;
				vis[prime[i]] = 1;
				next.step = t.step + 1;
				next.value = prime[i];
				//cout<<prime[i]<<endl;
				q.push(next);
			}
		}
	}
	return false;
}

int main()
{
	int count = 0;
	for(int i=2;i<10000;i++){
		if(!b[i]){
			a[count++] = i;
			for(int j=2*i;j<10000;j+=i){
				b[j] = 1;
			}
		}
	}
	for(int i=0;i<count;i++){
		if(a[i]>1000){
			prime[p++] = a[i];
		}
	}
	/*for(int i=0;i<p;i++){
		cout<<prime[i]<<endl;
	} */
	
	int t;
	//cout<<judge(1033, 1133);
	/*cout<<p<<endl;
	for(int i=0;i<p;i++)
		cout<<vis[prime[i]]<<endl;
	*/
	cin>>t;
	while(t--){
		int n, m;
		cin>>n>>m;
		if(bfs(n,m)){
			cout<<ans<<endl;
		}
		else{
			cout<<"Impossible"<<endl;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值