pat 1092. To Buy or Not to Buy (20)

1092. To Buy or Not to Buy (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.


Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY
Sample Output 1:
Yes 8
Sample Input 2:
ppRYYGrrYB225
YrR8RrY
Sample Output 1:
No 2
解: 写的比较烂,普通思路,代码比较冗长。

   如果buyer出现的字符均出现在owner里,即Yes,还需要买的数量等于第一个字符串长减去第二个字符串长,需要讲的一点就是每一次遍历要对已经查到的字符进行标记,即我们要保证buyer出现的字符个数应该在owner里都有,比如Y,buyer里出现两个,那么owner里也至少应该有两个,这里我对已经查到的字符标记为@。 

   如果buyer出现的某个字符,在owner里没有找到,即No,缺的个数可以在遍历中利用变量进行累加计数,我用的是变量cnt。

代码:

#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    string owner;
    string buyer;
    while(cin>>owner>>buyer)
    {
        int len1=owner.length();
        int len2=buyer.length();
        int cnt=0;
        int *flag=new int[len2+1];
        for(int i=0;i<len2;i++)
        {
            flag[i]=0;
            for(int j=0;j<len1;j++)
            {
                if(buyer[i]==owner[j])
                {
                    flag[i]=1;
                    owner[j]='@';
                    break;
                }
            }
            if(flag[i]==0)
            {
                cnt++;
            }
        }
        int choice=0;
        for(int i=0;i<len2;i++)
        {
            if(flag[i]==0)
            {
                choice=1;
            }
        }
        if(choice==1)
            cout<<"No"<<" "<<cnt<<endl;
        if(choice==0)
            cout<<"Yes"<<" "<<len1-len2<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值