【扩展中国剩余定理求解 && 逆元求解】POJ2891 Strange Way to Express Integers

Strange Way to Express Integers

Time Limit: 1000MS Memory Limit: 131072K
Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:
Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).
Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9
Sample Output

31
Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.
题目大意:给出一系列的同余方程式 x ≡ r i ( m o d   a i ) x \equiv r_i(mod \ a_i) xri(mod ai),求满足所有条件的整数
分析:由于题面中并未说明是两两互质的,所以要使用扩展中国剩余定理



下面是参考 https://yzmduncan.iteye.com/blog/1323599/ 将两个同余式合并为一个,通过逆元求解的方法:


上述费马小定理求解逆元,由于不确定 n 2 / d n_2/d n2/d是否为质数,所以排除;欧拉定理求 φ ( n ) \varphi(n) φ(n),数据类型为long long 会超时,所以最后用了扩欧求的逆元。

//扩展中国剩余定理求法
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define LL long long
#define Maxn 10010
using namespace std;
LL k, a1, r1, a2, r2;
LL extended_gcd(LL a, LL b, LL &x, LL &y) {
	if(b == 0) {
		x = 1;
		y = 0;
		return a;
	}
	LL gcd = extended_gcd(b, a % b, x, y);
	LL tem = x;
	x = y;
	y = tem - a / b * y;
	return gcd;
}
int main() {
	LL c, x, y, flag;
	while(~scanf("%lld", &k)) {
		flag = 1;
		scanf("%lld%lld", &a1, &r1);
		for(int i = 1; i < k; ++i) {
			scanf("%lld%lld", &a2, &r2);
			c = r2 - r1;
			if(flag == 0)
				continue;
			LL gcd = extended_gcd(a1, a2, x, y);
			if(c % gcd)
				flag = 0;
			LL tem = a2 / gcd;
			x = ((c / gcd * x) % tem + tem) % tem;
			r1 = r1 + a1 * x;
			a1 = a1 / gcd * a2;
			r1 = ((r1 % a1) + a1) % a1;
			cout << r1 << endl;
		}
		if(flag)
			cout << r1 << endl;
		else 
			cout << -1 << endl; 
	}
	return 0;
}
//通过逆元求解:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define LL long long 
using namespace std;
LL k, a1, r1, a2, r2;
LL gcd(LL a, LL b) {
	return b == 0 ? a : gcd(b, a % b);
}
LL extended_gcd(LL a, LL b, LL &x, LL &y) {
	if(b == 0) {
		x = 1;
		y = 0;
		return a;
	}
	LL gcd = extended_gcd(b, a % b, x, y);
	LL tem = x;
	x = y;
	y = tem - a / b * y;
	return gcd;
}
int main() 
{
	while(~scanf("%lld", &k)) {
		int flag = 1;
		cin >> a1 >> r1;
		for(int i = 1; i < k; ++i) {
			cin >> a2 >> r2;
			LL c = r2 - r1;
			LL d = gcd(a1, a2);
			if(c % d)
				flag = 0;
			if(flag == 0)
				continue;
			LL x, y;
			LL gcd = extended_gcd(a1/d, a2/d, x, y);
			x = ((c / d * x) % (a2/d) + (a2/d)) % (a2/d);
			r1 = a1 * x + r1;
			a1 = (a1 * a2) / d;
		}
		if(flag)
			cout << r1 << endl;
		else 
			cout << -1 << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值