hd1212

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 
Output
For each test case, you have to ouput the result of A mod B.
 
Sample Input
  
  
2 3 12 7 152455856554521 3250
 
Sample Output
  
  
2 5 1521
 
题目大意就是说给一很长的数字,需要用数组来存的,再给一小于100000的数,求字符串表示的数对这个数的余数。
不会,然后看的人家用的同余定理结合秦九韶公式来做的,然后才写出现在的代码
 
//4)同余定理a+b≡x+m (mod d)
//其中 a≡x (mod d),b≡m(mod d)
//6)a*b≡x*m (mod d )
//其中a≡x (mod d),b≡m (mod d)
//秦九韶算法f(x)=a(n)x^n+a(n-1)x^(n-1)+....=x(a(n)x^(n-1)+a(n-1)x^(n-2)+... 
#include<stdio.h>
#include<string.h>
char a[1001];
int aa[1001];
int main()
{
	int b,lena,i,y;
	while(scanf("%s %d",a,&b)==2)
	{
		lena=strlen(a);
		for(i=0;i<lena;++i)
		aa[i]=a[i]-'0';
                  y=0;
		for(i=1;i<lena;++i)
		{
			aa[i]+=(aa[i-1]*10)%b;
		}
		y=aa[lena-1]%b;
		printf("%d\n",y);
	}
	return 0;
}

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值