HDOJ 2803 The MAX【水题】

The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2057    Accepted Submission(s): 893


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 


Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 


Output
For each test case, output the biggest value of F you can find on a line.
 


Sample Input
  
  
2 1 2 0
 


Sample Output
  
  
4017


恩,题目大意就是说,给 n 个数,然后求与 n 个对应的数相乘之和的最大值,这 n 个对应的数之和小于等于2009 。刚开始一看题以为不简单就没写,之后回头来想了想,没想到真的就是这样的。。。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 110
using namespace std;
__int64 rec[maxn];
int main()
{
    int n;
    __int64 sum;
    while(scanf("%d",&n)&&n)
    {
        sum=0;
        for(int i=0;i<n;++i)
            scanf("%I64d",&rec[i]);
        sort(rec,rec+n);
        for(int i=0;i<n-1;++i)
        {
            sum+=rec[i];
        }
        sum+=rec[n-1]*(2009-n+1);
        printf("%I64d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值