POJ 2777 Count Color 【线段树 区间更新 按位或运算】

Count Color

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40183 Accepted: 12127

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1


恩,题目大意就是说,一块木板,初始颜色为1号,然后给不同的区间染色,问知道区间内的颜色个数。刚开始做,各种不对啊,看人家题解,里面的按位或运算完全不懂啊,不懂啊。。。。。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100000
using namespace std;
int l,t,q,sum=0;
struct lnode
{
    int l,r,c;
    bool f;
};
lnode node[maxn<<2];
void pushup(int o)
{
    node[o].c=node[o<<1].c|node[o<<1|1].c;
}
void build(int o,int l,int r)
{
    node[o].l=l;
    node[o].r=r;
    node[o].c=1;
    node[o].f=true;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(o<<1,l,mid);
    build(o<<1|1,mid+1,r);
}
void pushdown(int o)
{
    if(node[o].f)
    {
        node[o<<1].c=node[o<<1|1].c=node[o].c;
        node[o<<1].f=node[o<<1|1].f=true;
        node[o].f=false;
    }
}
void update(int o,int l,int r,int x)
{
    if(node[o].l==l&&node[o].r==r)
    {
        node[o].c=x;
        node[o].f=true;
        return ;
    }
    if(node[o].c==x)
        return ;
    pushdown(o);
    int mid=(node[o].l+node[o].r)>>1;
    if(r<=mid)
        update(o<<1,l,r,x);
    else if(l>mid)
        update(o<<1|1,l,r,x);
    else
    {
        update(o<<1,l,mid,x);
        update(o<<1|1,mid+1,r,x);
    }
    pushup(o);
}
void query(int o,int l,int r)
{
    if(node[o].l>=l&&node[o].r<=r)
    {
        sum|=node[o].c;
        return ;
    }
    if(node[o].f)
    {
        sum|=node[o].c;
        return ;
    }
    int mid=(node[o].l+node[o].r)>>1;
    if(r<=mid)
        query(o<<1,l,r);
    else if(l>mid)
        query(o<<1|1,l,r);
    else
    {
        query(o<<1,l,mid);
        query(o<<1|1,mid+1,r);
    }
}
int get(int sum)
{
    int ans=0;
    while(sum)
    {
        if(sum&1)
            ans++;
        sum>>=1;
    }
    return ans;
}
int main()
{
    int a,b,x;
    char c;
    while(~scanf("%d%d%d",&l,&t,&q))
    {
        build(1,1,l);
        while(q--)
        {
            getchar();
            scanf("%c",&c);
            sum=0;
            if(c=='C')
            {
                scanf("%d%d%d",&a,&b,&x);
                if(a>b)
                {
                    int tem=a;
                    a=b;
                    b=tem;
                }
                update(1,a,b,1<<(x-1));
            }
            else
            {
                scanf("%d%d",&a,&b);
                if(a>b)
                {
                    int tem=a;
                    a=b;
                    b=tem;
                }
                query(1,a,b);
                printf("%d\n",get(sum));
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值