HDOJ 5443 The Water Problem 【RMQ 模板题】

The Water Problem

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 981    Accepted Submission(s): 781


Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with  a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing  2  integers  l  and  r , please find out the biggest water source between  al  and  ar .
 

Input
First you are given an integer  T(T10)  indicating the number of test cases. For each test case, there is a number  n(0n1000)  on a line representing the number of water sources.  n  integers follow, respectively  a1,a2,a3,...,an , and each integer is in  {1,...,106} . On the next line, there is a number  q(0q1000)  representing the number of queries. After that, there will be  q  lines with two integers  l  and  r(1lrn)  indicating the range of which you should find out the biggest water source.
 

Output
For each query, output an integer representing the size of the biggest water source.
 

Sample Input
3110011 151 2 3 4 551 21 32 43 43 531 999999 141 11 22 33 3
Sample Output
  
  
100 2 3 4 4 5 1 999999 999999 1

恩,题目大意就是说,找区间内最大值,模板题,直接套


#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 1010
using namespace std;
int n,a[maxn];
int amax[maxn][20];
int max(int a,int b)
{
    return a>b?a:b;
}
void init()
{
    for(int i=1;i<=n;++i)
        amax[i][0]=a[i];
    for(int j=1;1<<j <=n;++j)
    {
        for(int i=1;i+(1<<j)-1 <=n;++i)
            amax[i][j]=max(amax[i][j-1],amax[i+(1<<(j-1))][j-1]);
    }
}
int query(int l,int r)
{
    int k=0;
    while((1<<(k+1))<=(r-l+1))
        k++;
    return max(amax[l][k],amax[r-(1<<k)+1][k]);
}
int main()
{
    int t,q,l,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
            scanf("%d",&a[i]);
        init();
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&l,&r);
            printf("%d\n",query(l,r));
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值