UVA 1339 Ancient Cipher【水。。。】

1339 - Ancient Cipher

Time limit: 3.000 seconds

Ancient Roman empire had a strong government system with various departments, including a secretservice department. Important documents were sent between provinces and the capital in encryptedform to prevent eavesdropping. The most popular ciphers in those times were so called substitutioncipher and permutation cipher

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for allletters must be different. For some letters substitute letter may coincide with the original letter. Forexample, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in thealphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.

Permutation cipher applies some permutation to the letters of the message. For example, applyingthe permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message“IVOTCIRSUO”.

It was quickly noticed that being applied separately, both substitution cipher and permutationcipher were rather weak. But when being combined, they were strong enough for those times. Thus,the most important messages were first encrypted using substitution cipher, and then the result wasencrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination ofthe ciphers described above one gets the message “JWPUDJSTVP”.

Archeologists have recently found the message engraved on a stone plate. At the first glance itseemed completely meaningless, so it was suggested that the message was encrypted with some substitutionand permutation ciphers. They have conjectured the possible text of the original message thatwas encrypted, and now they want to check their conjecture. They need a computer program to do it,so you have to write one

Input

Input file contains several test cases. Each of them consists of two lines. The first line contains themessage engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, sothe encrypted message contains only capital letters of the English alphabet. The second line containsthe original message that is conjectured to be encrypted in the message on the first line. It also containsonly capital letters of the English alphabet

The lengths of both lines of the input file are equal and do not exceed 100.

Output

For each test case, print one output line. Output ‘YES’ if the message on the first line of the input filecould be the result of encrypting the message on the second line, or ‘NO’ in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES

Sample Output

YES
NO
YES
YES
NO


题目大意就是说,第一个字符串能否由第二个字符串通过任意调换位置之后再每个对应字母分别向后移任意位得到(每个字母向后移的位数是相同的)例子可看题目描述中给的例子。然后因为可以随意调换位置,那么字母的顺序就不重要了,只需记录一下每个字母出现的次数,然后排序比较一下即可。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 110
using namespace std;
char s[maxn],t[maxn];
int ss[30],tt[30];
int main()
{
    while(~scanf("%s%s",t,s))
    {
        memset(ss,0,sizeof(ss));
        memset(tt,0,sizeof(tt));
        int lens=strlen(s);
        int lent=strlen(t);
        for(int i=0;i<lens;++i)
            ss[s[i]-'A']++;
        for(int i=0;i<lent;++i)
            tt[t[i]-'A']++;
        sort(ss,ss+26);
        sort(tt,tt+26);
        int flag=1;
        for(int i=0;i<26;++i)
        {
            if(ss[i]!=tt[i])
            {
                flag=0;
                break;
            }
        }
        if(!flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值