UVa 489 Hangman Judge

Hangman Judge

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.


恩,最重要的是把题面读懂啊。题目大意就是说,猜单词,第一个为要猜的单词A,第二个为你猜的单词B,若猜错7次则输,若在7次之前既没输也没赢视为弃权。

注意 :1   你猜出A中一个字母则A中所有该字母都表示被猜出了  

2  然后猜错一个字母,往后再猜该单词表示只记为错一次  

3   再次猜之前猜对的字母视为猜错,例如第一次猜 c 对了,则再次猜c 为错

4   猜对整个单词之后就立即视为赢即使是这种情况(cheese    chesabcdefghij  )


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 110
using namespace std;
char s[maxn],t[maxn];
int ss[30];
int main()
{
    int tt,cnt,num;
    while(scanf("%d",&tt)&&(tt!=-1))
    {
        cnt=7,num=0;
        scanf("%s%s",s,t);
        memset(ss,0,sizeof(ss));
        int lens=strlen(s);
        int lent=strlen(t);
        for(int i=0;i<lens;++i)
        {
            if(!ss[s[i]-'a'])
            {
                num++;
                ss[s[i]-'a']=1;
            }
        }
        for(int i=0;i<lent;++i)
        {
            int tem=t[i]-'a';
            if(ss[tem]==1)
            {
                num--;
                ss[tem]=0;
            }
            else if(ss[tem]==0)
            {
                ss[tem]=-1;
                cnt--;
            }
            if(cnt==0)
                break;
            if(num==0)
                break;
        }
        printf("Round %d\n",tt);
        if(cnt==0)
        {
            printf("You lose.\n");
            continue;
        }
        if(num!=0)
            printf("You chickened out.\n");
        else
            printf("You win.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值