HDOJ 5233 Gunner II【二分&&邻接表】

Gunner II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1796    Accepted Submission(s): 659


Problem Description
Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.
 

Input
There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)
 

Output
For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.
 

Sample Input
  
  
5 5 1 2 3 4 1 1 3 1 4 2
 

Sample Output
  
  
1 3 5 4 2
Hint
Huge input, fast IO is recommended.

恩,题意大致是,一排树,每棵树树顶有一只鸟,给出这排树的树高,然后猎人要拿枪打鸟,给出猎人枪的高度,每次会击落与猎人枪同高度的离他最近的一只鸟,要输出这只鸟的编号,如果没有击中鸟输出-1。由于树高的范围很大,所以这里离散化,然后邻接表记录一下编号。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#define maxn 100010
using namespace std;

int h[maxn],q[maxn];
int rr[maxn*2];
int bsearch(int l,int r,int aim)
{
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(rr[mid]==aim)
            return mid;
        else if(rr[mid]>aim)
            r=mid-1;
        else
            l=mid+1;
    }
}
struct node
{
    int t,next;
};
node edge[maxn*2];//这里数组开小了WA死。。。
int head[maxn*2];
int cnt;
void add(int f,int t)
{
    edge[cnt].t=t;
    edge[cnt].next=head[f];
    head[f]=cnt++;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int k=0;
        memset(h,0,sizeof(h));
        memset(q,0,sizeof(q));
        memset(rr,0,sizeof(rr));
        memset(edge,0,sizeof(edge));
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&h[i]);
            rr[k++]=h[i];
        }
        for(int i=1;i<=m;++i)
        {
            scanf("%d",&q[i]);
            rr[k++]=q[i];
        }
        sort(rr,rr+k);
        k=unique(rr,rr+k)-rr;
        for(int i=1;i<=n;++i)
            h[i]=bsearch(0,k,h[i]);
            //h[i]=lower_bound(rr,rr+k,h[i])-rr;
        for(int i=1;i<=m;++i)
            q[i]=bsearch(0,k,q[i]);
            //q[i]=lower_bound(rr,rr+k,q[i])-rr;
        cnt=0;
        memset(head,-1,sizeof(head));
        for(int i=n;i>=1;--i)
            add(h[i],i);
        for(int i=1;i<=m;++i)
        {
            int j=head[q[i]];
            if(j!=-1)
            {
                printf("%d\n",edge[j].t);
                head[q[i]]=edge[j].next;
            }
            else
                printf("-1\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值