Whu oj 1604 - Play Apple

3 篇文章 0 订阅

Problem 1604 - Play Apple

Time Limit: 1000MS   Memory Limit: 65536KB  
Total Submit: 422  Accepted: 171  Special Judge: No
Description

There are N apples. Two people take turns to either:
1. Divide the apple into two piles with different numbers.
2. The other people selects a pile of apples as the beginning of the next turn.
If someone can not meet the requirements, he is lost. Will the first one win the game if both use the best strategy?

Input
There are multiple test cases.
The first line of each case contains a integer N. ( 1 <= N <= 1000000000 )
Output
If the first person will win, output “Yes”. Otherwise, output “No”.
Sample Input
2
3
4
Sample Output
No
Yes
No

从1和2 开始考虑,之后规律就出来了

1 N  2N  3Y  4N 5Y 6Y 7N  8Y 9Y  10N 

#include<cstdio>
 #include<cstring>
 #include<algorithm>
 using namespace std;
int main()
 {
     int n;
     while(scanf("%d",&n)!=EOF)
     {
         if(n==2)
         {
             printf("No\n");
             continue;
         }
         int t=n%3;
         if(!t)
             printf("Yes\n");
         if(t==1)
             printf("No\n");
         if(t==2)
             printf("Yes\n");
     }
     return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值