NYOJ 148 fibonacci数列(二)【矩阵快速幂】

fibonacci数列(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875
来源
POJ

快速幂,和数的快速幂相同,只是这里要先定义矩阵的乘法

数的快速幂完整易理解博客http://blog.csdn.net/xuruoxin/article/details/8578992

关于二进制的解释 http://blog.csdn.net/y990041769/article/details/22311889


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
#define N 2
#define MOD 10000
using namespace std;
LL f1,f2;
struct Mat
{
    LL mat[N][N];
};
Mat operator * (Mat a,Mat b)
{
    Mat c;
    memset(c.mat,0,sizeof(c.mat));
    for(int i=0;i<2;++i)
    {
        for(int k=0;k<2;++k)
        {
            for(int j=0;j<2;++j)
            {
                c.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                c.mat[i][j]%=MOD;
            }
        }
    }
    return c;
}
Mat operator ^ (Mat a,LL k)
{
    Mat c;
    for(int i=0;i<2;++i)
    {
        for(int j=0;j<2;++j)
            c.mat[i][j]=(i==j?1:0);
    }
    while(k)
    {
        if(k&1)
            c=c*a;
        a=a*a;
        k=k>>1;
    }
    return c;
}
int main()
{
    LL n;
    while(scanf("%lld",&n)&&(n!=-1))
    {
        if(n==0)
            printf("0\n");
        else
        {
            Mat nn;
            nn.mat[0][0]=nn.mat[0][1]=nn.mat[1][0]=1;
            nn.mat[1][1]=0;
            Mat p=nn^n;
            printf("%lld\n",p.mat[0][1]);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值