POJ 3903 Stock Exchange【LIS 二分查找】

Stock Exchange

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5914 Accepted: 2072

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

 

嗯,题意是求最长上升子序列,O(n^2)复杂度会超时吧,这里手写了二分查找。相当于把原序列中的数按顺序插入进去,取代其中第一个比它大或和它相等的数的位置上。

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define maxn 100010
#define inf 0x3f3f3f3f
using namespace std;
int dp[maxn];
int num[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;++i)
            scanf("%d",&num[i]);
        memset(dp,inf,sizeof(dp));
        num[n]=inf;
        for(int i=0;i<=n;++i)
        {
            int l=0,r=n,rec=0;
            while(l<=r)
            {
                int mid=(l+r)>>1;
                if(dp[mid]>=num[i])
                {
                    r=mid-1;
                    rec=mid;
                }
                else
                    l=mid+1;
            }
            dp[rec]=num[i];
            if(i==n)
            {
                printf("%d\n",rec);
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值