PAT甲级-1002. A+B for Polynomials (25)

  1. A+B for Polynomials (25)

时间限制 400 ms
内存限制 65536 kB
代码长度限制 16000 B
判题程序 Standard
作者 CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output3 2 1.5 1 2.9 0 3.2

题目大意:多项式合并,指数相同的系数相加,最后输出

学习使用了pair和vector 然后浮点数判0

#include <iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<utility>
using namespace std;

int main()
{
    typedef pair<int,double>P;
    typedef vector< pair<int,double> >VP;
    VP vp,vq,vs;
    P p;
    int a,b;
    scanf("%d",&a);
    while(a--){
        scanf("%d%lf",&p.first,&p.second);
        vp.push_back(p);
    }
    scanf("%d",&b);
    while(b--){
        scanf("%d%lf",&p.first,&p.second);
        vq.push_back(p);
    }
    VP::iterator it=vp.begin();
    VP::iterator ir=vq.begin();
    while(it!=vp.end()||ir!=vq.end()){
        if(it!=vp.end()&&ir!=vq.end()&&it->first==ir->first){
            p.first=it->first;
            p.second=it->second+ir->second;
            ir++;
            it++;
        }
        else if((ir==vq.end()&&it!=vp.end())||it->first>ir->first){
            p.first=it->first;
            p.second=it->second;
            it++;
        }
        else if((it==vp.end()&&ir!=vq.end())||it->first<ir->first){
            p.first=ir->first;
            p.second=ir->second;
            ir++;
        }
        if(p.second<1e-15&&p.second>-1e-15)
            continue;
        else
            vs.push_back(p);
    }
    it=vs.begin();
    printf("%d",vs.size());
    for(it;it!=vs.end();it++){
        printf(" %d %.1lf",it->first,it->second);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值