PAT(甲级)1007. Maximum Subsequence Sum (25)

Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

题目大意:求最大连续子序列和 输出最大子序列和 以及子序列的首尾的值(不是序号。。。表问我为什么强调 宝宝委屈)然后还要序号最小 另外当所有元素都为负数时 默认最大和为0 同时输出第一位和最后一位的值
分析:最大连续子序列和 子序列一定是在某一位结束,所以记录以其前一位结尾的最大和 再更新以当前位结束的最大和 记录最大值与首尾值

/*
10
-10 2 7 -8 4 6 -23 3 7 -21
5
-2 -3 3 4 5
*/
#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 10010
using namespace std;

int main()
{
    int k;
    int num[maxn];
    int maxs,nsum;
    int s,e,t;
    scanf("%d",&k);
    for(int i=0;i<k;++i)
        scanf("%d",&num[i]);
    maxs=num[0],nsum=num[0];
    s=num[0],e=s,t=s;
    for(int i=1;i<k;++i){
        if(nsum>=0)//要求首尾序号最小
            nsum+=num[i];
        else{
            nsum=num[i];
            t=num[i];//记录开始位置的值
        }
        if(nsum>maxs){
            maxs=nsum;
            e=num[i];//记录最大子序列和的结束位置的值
            s=t;//开始位置的值
        }
    }
    if(maxs<0)//全为负数的情况
        printf("0 %d %d",num[0],num[k-1]);
    else
        printf("%d %d %d",maxs,s,e);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值