Product of Polynomials (25)
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
题目大意:求两个多项式相乘 输出格式与输入格式相同 指数小于等于1000
分析:首先没想到暴力能过 其次没想到对精度要求挺低
#include <iostream>
#include<cstdio>
#include<cstring>
#include<utility>
#define maxn 2020
using namespace std;
int check(double d){
if(d<1e-15&&d>-1e-15)//以为这里要改为1e-1 不然之后计数会出错 结果都行
return 0;
return 1;
}
int main()
{
int k,e,cnt=0;
double a[maxn],b[maxn],pd[maxn];
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(pd,0,sizeof(pd));
scanf("%d",&k);
for(int i=0;i<k;++i){
scanf("%d",&e);
scanf("%lf",&a[e]);
}
scanf("%d",&k);
for(int i=0;i<k;++i){
scanf("%d",&e);
scanf("%lf",&b[e]);
}
for(int i=0;i<=1000;++i){
if(check(a[i])){
for(int j=0;j<=1000;++j){
if(check(b[j]))
pd[i+j]+=(a[i]*b[j]);
}
}
}
for(int i=0;i<=2000;++i)
if(check(pd[i]))
cnt++;
printf("%d",cnt);
for(int i=2000;i>=0;i--){
if(check(pd[i]))
printf(" %d %.1lf",i,pd[i]);
}
return 0;
}