动态规划--HDU--1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 150602    Accepted Submission(s): 35169


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6 对于这道题,是要具有动态规划的思想。要随时进行更新数据。
记住要将初始位置和结束位置进行初始赋值,以防从第一个给出的数据开始以后的数据都是依次递减,则最大的和即为第一个数本身。

#include<iostream>
using namespace std;
int main()
{
   int T;//记录数据的组数。
   cin>>T;
   int i=2;
   int Ti=0;
    for(int p=1;p<=T;p++)
   {
       Ti++;
       int n,data;//n为第一组数据的组数,data为第一组数据的第一个数。
       cin>>n>>data;
       int S_pos,E_pos,x;//S_pos指开始时的位置,同样,E_pos值结束时的位置。
       S_pos=E_pos=x=1;
       //要进行数据的比对,如果第二个数据+第一个数据小于第二个数据,则可以更新最大和的起始位置。
       int now=data;//now代表的是随时进行更新的一个当前的和值。
       //应该还要进行一个max的定义,好进行与当前的和值的比对,以随时进行更新。
       int max=data;


       for(i=2;i<=n;i++)
       {
           //开始录入第二至最后一个数据。
           cin>>data;
           if(now+data<data)
           {
               //进行位置和当前值的更新。
               now=data;
               x=i;
           }
           else
           {
               now=now+data;
           }
           if(now>max)
           {
               max=now;
               S_pos=x;
               E_pos=i;
           }
       }
           //注意输出的格式要求两行中间还要输出一行空格。
           cout<<"Case "<<Ti<<":"<<endl;
           cout<<max<<" "<<S_pos<<" "<<E_pos<<endl;
           if(p!=T)
           {
               cout<<endl;
           }

       }
       return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值