ACM--steps--3.2.4--Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 914 Accepted Submission(s): 493
 
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
 
 
Source
University of Ulm Local Contest 1996
 
Recommend
JGShining

#include<iostream>
using namespace std;
long long dyx[5900];
const long long N=2000000005;
int main()
{
    int wyx[4]={2,3,5,7};//4个质因子。
    //求的humble number可以看出来只由2,3,5,7的倍数构成。
    //第2个数2,3,5,7的倍数中最小的。第3个数是2^2,3,5,7中最小的,以此类推。
    //因为大的数肯定在后面出现。
    dyx[1]=1;
    for(int i=2;i<=5843;i++)
    {
        dyx[i]=N;//以便与下面的数进行比较。
        for(int j=0;j<4;j++)//进行4个质因子的乘法运算。
        {
            for(int k=i-1;k>=1;k--)//k=i-1,是先与最大的那个数进行比较。
            {
                //得出的数列肯定是递增的数列。                
                if(dyx[k]*wyx[j]<=dyx[i-1])
                break;
                if(dyx[k]*wyx[j]<dyx[i])
                dyx[i]=dyx[k]*wyx[j];//取最小的那个值。
            }
        }
    }
    //英文单词,第1,2,3分别为st,nd,rd,但是11,12,13,和大于100以上以11,12,13结尾的以th结尾。
    int a;
    while(cin>>a&&a)
    {
        cout<<"The "<<a;
        if(a%10==1&&a%100!=11)
        cout<<"st ";
        else if(a%10==2&&a%100!=12)
        cout<<"nd ";
        else if(a%10==3&&a%100!=13)
        cout<<"rd ";
        else
        cout<<"th ";
        cout<<"humble number is "<<dyx[a]<<"."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值