ACM--steps--4.1.2--Strange fuction(二分找答案)

Strange fuction

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 504 Accepted Submission(s): 429
 
Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 
Output

            Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 
Sample Input
2
100
200
 
Sample Output
-74.4291
-178.8534
 
Author
Redow
 
 
Recommend
lcy


#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
using namespace std;
//表示原方程式
double dyx(double x,double y)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
//导数方程。
double wyx(double x,double y)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        //x的范围0~100.所以 6 * x^7+8*x^6+7*x^3+5*x^2>0恒成立。
        //当x=100时,如果函数值还<=0.则函数为单调递减,x=100即为所求的最小值。
        //当x=0时,如果函数值>=0,则函数为单调递增函数,x=0即为所求的最小值。
        double x1,x2,x3,y,y1,y2,y3,ans;
        cin>>y;
        if(wyx(0.0,y)>=0)
        cout<<fixed<<setprecision(4)<<dyx(0.0,y)<<endl;
        else if(wyx(100.0,y)<=0)
        cout<<fixed<<setprecision(4)<<dyx(100.0,y)<<endl;
        else
        {
            //二分
            x1=0.0;
            x2=100.0;
            y1=wyx(x1,y);
            y2=wyx(x2,y);
            while(fabs(y1-y2)>0.0001)
            {
                x3=(x1+x2)/2;
                y3=wyx(x3,y);
                if(y3>0)
                x2=x3;//更新右端点。
                else
                x1=x3;
                y1=wyx(x1,y);
                y2=wyx(x2,y);
            }
            cout<<fixed<<setprecision(4)<<dyx(x3,y)<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值