ACM--steps--4.3.2--Prime Ring Problem

16 篇文章 0 订阅
8 篇文章 0 订阅

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 497 Accepted Submission(s): 304
 
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 
Input
n (0 < n < 20).
 
Output

            The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
Sample Input
6
8
 
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
 
Source
Asia 1996, Shanghai (Mainland China)
 
Recommend
JGShining

格式错了得有800遍;
dyx,我后悔了

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
int dyx[29];//输入的数组。
int n;//素数环的长度。
bool vis[29];//每个数字只能使用一次.
bool judge_pri(int num)
{
    //判断素数的时候只需要循环到开方即可.
    for(int i=2;i<=sqrt(num*1.0);i++)
    {
        if(num%i==0)
        return false;
    }
    return true;
}
void dfs(int num)
{
    //num表示当前一共找到了num个合适的数字。
    //用dfs主要是进行状态的回溯,暴力搜索,一个数字不行,回溯到初始的状态再次进行尝试.
    if(num==n&&judge_pri(1+dyx[n-1]))
    {
        //judge_pri(1+dyx[n-1])表示最后一个数字已经符合要求,和它前面一个数字相加依然是素数。
            //printf(i==n-1?"%d\n":"%d ",dyx[i]);
            for(int i=0;i<n-1;i++)
            cout<<dyx[i]<<" ";
            cout<<dyx[n-1]<<endl;
    }
    else
    {
         for(int i=2;i<=n;i++)
    {
        if(!vis[i]&&judge_pri(i+dyx[num-1]))
        {
            dyx[num]=i;
            vis[i]=true;//这个数字已经被使用,每个数字在vis里的位置是不会变得。
            dfs(num+1);
            vis[i]=false;
        }
    }
    }
}
void set()
{
    for(int i=0;i<n;i++)
    {
        vis[i]=false;
    }
    dyx[0]=1;
}
int main()
{
    int cnt=1;
    while(scanf("%d",&n)!=EOF)
    {
        //dyx[0]=1;
        //memset(vis,0,sizeof(vis));
        set();
        cout<<"Case "<<cnt++<<":"<<endl;
        dfs(1);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值