ACM--steps--dyx--2.3.2--Exponentiation

Exponentiation

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1995 Accepted Submission(s): 545
 
Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
 
Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 
Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 
Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12
 
Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
 
 
Source
East Central North America 1988
 
Recommend
PrincetonBoy
 

#include<iostream>
using namespace std;
int len;
int dyx[509];
int big_mult(int a[],int num)
{
    int flag=0;//记录进位。
    int i;//同样用以记录位数。
    //大数相乘,将大数全部化为对应的整数,记录小数点应该有的位置,然后插入小数点.
    for(i=0;i<len;i++)
    {
        //num记录的是原数据;
        //wyx记录的是每一位的数据。
        //dyx[i]表示的是在乘法的竖式计算当中,每一位的答案.
        //flag则表示的是每一位需要进位的位数.
        /*1  2  3  4  5
        x 1  2  3  4  5
      -------------------
          6  1  7  2  5
       4  9  3  8  0
        */
        //dyx[i]记录的是每一步的6 1 7 2 5这几个值,flag记录的是进位的位数,比如5x5=25;flag记录的是2;
        int wyx=dyx[i]*num+flag;
        dyx[i]=wyx%10;
        flag=wyx/10;
    }
    while(flag)
    {
        dyx[i++]=flag%10;
        flag/=10;
    }
    len=i;
    return 0;
}
int main()
{
    string a;
    int n;//输入的数据,和n次幂
    while(cin>>a>>n)
    {
        int i=0;
        //将浮点型的数据转化为整型的数据.
        int flag=0;//flag记录的是小数点有几位;
        int num=0;//num记录的是将浮点型的数据转化为整型的数据
        for(;i<6;i++)
        {
            if(a[i]=='.')
            flag=(5-i)*n;
            else
            num=num*10+(a[i]-'0');
        }
        //还有两个条件没有进行判定、
        //1,a的1次幂的情况/.
        if(n==1&&flag==0)
        cout<<num<<endl;//若为1次幂,有后缀零,且为浮点型的数据还是不可以直接输出.
        else if(num==0)
        cout<<num<<endl;//当数据本身为0的时候,直接输出.
        else
        {
         len=1;
        dyx[0]=1;
        for(i=0;i<n;i++)
        {
            big_mult(dyx,num);
        }
            //接下来判断len和flag的长度
        //小数点的位数大于整个整型的位数.
        if(flag>len)
        {
            int j=0;
            //注意消去后缀0;
            while(dyx[j]==0)
            j++;
            cout<<'.';
            while(flag>len)
            {
                cout<<'0';
                flag--;
            }
            for(int i=len-1;i>=j;i--)
            {
                cout<<dyx[i];
            }
        }
        else
        {
            int j=0;
            //消去小数点后面的0;
            while(dyx[j]==0&&j<flag)
            j++;
            flag=len-flag;
            for(i=len-1;i>=j;i--)
            {
                if(flag==0)
                cout<<'.';
                cout<<dyx[i];
                flag--;
            }
        }
        cout<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值