Reverse Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8928 Accepted Submission(s): 3889
Problem Description
Welcome to 2006'4 computer college programming contest!
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
Output
For each test case, you should output its reverse number, one case per line.
Sample Input
3 12 -12 1200Sample Output
21 -21 2100
题目代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
char ch[20];
int main()
{
int i,N,j;
scanf("%d",&N);
while(N--)
{
scanf("%s",ch); //输入字符串
int t=0;
if(ch[0]=='-') //如果是负数先输出负号
{
printf("%c",ch[0]); //先输出-
for(i=strlen(ch)-1;i>0;i--)
{
if(ch[i]!='0')
break; //遇到第一个不为0的数就停止
else
t++; //冬季
}
for(j=i;j>0;j--)
printf("%c",ch[j]);
}
else
{
for(i=strlen(ch)-1;i>=0;i--)
{
if(ch[i]!='0')
break;
else
t++;
}
for(j=i;j>=0;j--)
printf("%c",ch[j]);
}
for(i=0;i<t;i++)
printf("0");
printf("\n");
}
return 0;
}