POJ 3522:Slim Span


Slim Span
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8033 Accepted: 4275

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.


Figure 5: A graph  G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of  G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

题目意思:

求一颗生成树,使其边的最大值与最小值的差相差最小,并输出最小差值,如果不存在生成树,输出-1.

观察题目时间限制给出了5秒。不是一般的长,虽然要从图的所有生成树中求最大边最小边的最小差值,需要求所有生成树,

我觉得不能怂,应该暴力试试,毕竟时间给5秒,很明显要暴力,所以就写了个特别暴力的代码。还真的过了,过的时间是63MS。说明

后面测试数据很弱。

解题思路:用Kruskal写。先对V条边的权值进行从大到小排序。然后依次按顺序选择边作为生成树的第一条边,开始求生成树。


#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f

using namespace std;

const int maxn = 103;
const int maxm = 100005;
int N,V;
int father[maxn];   ///并查集操作
int ans;
struct Edge
{
    int u;
    int v;
    int weight;
}edge[maxm];
///按边权值从大到小排序
bool cmp(struct Edge e1,struct Edge e2)
{
    return e1.weight<e2.weight;
}
void make_set()  ///并查集初始化操作
{
    for(int i = 1; i <= N; i++)
        father[i] = i;
}
int find_set(int x)
{
    int root = x;
    while(root != father[root])
    {
        root = father[root];
    }
    while(x != father[x]) ///路径压缩
    {
        int temp = father[x];
        father[x] = root;
        x = temp;
    }
    return root;
}
void union_set(int x,int y)
{
    father[x] = y;
}
int Kruskal(int start)  ///以第start条边开始求生成树
{
    int k = 0,j = start;
    make_set();         ///初始化并查集
    int min_edge = edge[start].weight; ///生成树最小的边
    while(j < V)
    {
        int u = edge[j].u;
        int v = edge[j].v;
        int fu = find_set(u);
        int fv = find_set(v);
        if(fu != fv)
        {
            union_set(fu,fv);
            k++;
        }
        if((edge[j].weight-min_edge) > ans) return -2;
        ///这一句是优化,如果当前边减去第一条边比当前ans大了,就结束。
        if(k == N-1)  ///最后选出的边是生成树最大的边
        {
            int temp = edge[j].weight-min_edge;
            return temp;
        }
        j++;
    }
    if(k < N-1)
        return -1;
}
int main()
{
    while(~scanf("%d%d",&N,&V))
    {
        if(N == 0 && V == 0) break;
        for(int i = 0; i < V; i++)
        {
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].weight);
        }
        sort(edge,edge+V,cmp);  ///对边的权值进行从小到大排序
        ans = inf;
        for(int i = 0; i < V; i++)
        {
            int temp = Kruskal(i);
            if(temp == -2) continue;
            if(temp == -1) break; ///说明从当前i开始已经选不出边去构成生成树了。
            ans = min(ans,temp);
        }
        if(ans == inf)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值