虐人的hd1001 Sum Problem

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050


首先看看自己开始写的代码,编译没错,结果没错,在是submit之后总是被Wrong Answer掉


#include<stdio.h>
void main()
{
	int a,sum=0;
	while(scanf("%d",&a)!=EOF)
	{
	sum=(a*(a+1))/2;
	printf("%d\n\n",sum); 
	}
}

       在这里,我是使用公式来计算的,因为这个求和和高中就学过的等差数列求和一样,打眼一看就知道使用公式。在心里偷偷高兴之后,被一次次Wrong Answer搞定想砸电脑 [偷笑]。纠结了半天之后开始仔细看要求,发现有这么一句重要的话被我或略掉了

You may assume the result will be in the range of 32-bit signed integer. 你可以假设结果将在32位符号整数的范围内。

原来这有限制条件,我之前完全忽略了。再重新检查一下我自己写的代码。我发现应该就是公式给用错。虽然sum=(a*(a+1))/2一定在32位整数范围内,但是

a*(a+1)却很容易造成溢出,超出范围于是把代码重新改了一下,重新submit,结果终于被Accept。

这里有2种方法,代码如下:

方法一:仍使用公式

#include<stdio.h>
int main()
{
    int a,sum;
    while(scanf("%d",&a)!=EOF)
    {
        if(a%2==0)
            sum=a/2*(a+1);//先除以2,就可以降低溢出的可能性 
         else
            sum=(a+1)/2*a;
        printf("%d\n\n",sum);
    }
    return 0;
}

方法二:循环

<pre name="code" class="cpp">#include <stdio.h>
int main()
{
 int a,i,sum=0;
 	 while(scanf("%d",&a)!=EOF)
 	 {
 	  if(a==1)
 	  	   {
  		    sum=1;
		   }
  			 else
  			 {
  			  for(i=0;i<=a;i++)
  			   {
  				    sum+=i;
			   }
			 }
	  printf("%d\n\n",sum);
       sum=0;
     }
 return 0;
}

 每次看到 
Accept都好开森啊[偷笑]。 


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值