Tight words (dp)

http://cpp.zjut.edu.cn/ShowProblem.aspx?ShowID=1003

Description:

Given is an alphabet {0, 1, ... , k}(0 <= k <= 9 ). We say that a word of length n over this alphabet is tight if any two neighbour digits in the word do not differ by more than 1. Input is a sequence of lines, each line contains two integer numbers k and n( 1 <= n <= 100). For each line of input, output the percentage of tight words of length n over the alphabet {0, 1, ... , k} with 5 fractional digits.

Sample Input:

4
12
53
587

Sample Output:

100.00000
40.74074
17.38281
0.10130


给定两个数k n

用1~k的数组成一个n个数的序列,如果这个序列每两个相邻的数相差不超过,就记为是tight,求这种序列占总序列的比例

#include<iostream>
#include<iomanip>
using namespace std;

double a[101][10];
int k,n;
int i,j;//loop
double s;

double d;


int main(){
	while(cin>>k>>n){
		if(k<=1){
			cout<<"100.00000\n";continue;}
		s=0;d=1;
		for(i=0;i<=k;i++)
			a[n][i]=1;
		
		for(j=n-1;j>0;j--)
		for(i=0;i<=k;i++)
		if(i==0)a[j][0]=a[j+1][0]+a[j+1][1];
		else
		if(i==k)a[j][k]=a[j+1][k]+a[j+1][k-1];
		else
			a[j][i]=a[j+1][i-1]+a[j+1][i]+a[j+1][i+1];
		for(i=0;i<=k;i++)
			s+=a[1][i];
		for(i=0;i<n;i++)
			d*=(k+1);
		/*for(j=n;j>0;j--){
		for(i=0;i<=k;i++)
			cout<<a[j][i]<<" ";cout<<endl;}
		cout<<s<<" "<<d<<endl;*/
		cout<<setprecision(5)<<fixed<<(100.0*s/d)<<endl;
	}
	return 0;
}


  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值