Description
Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2 3 3 1 2 1 2 3 2 3 1 3 4 4 1 2 2 2 3 2 3 4 2 4 1 2
Sample Output
3 Not Unique!
题意:判断最小生成树是否唯一
//Prim易懂
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int num,sum;
const int inf=999999999;
int map[1010][1010],p[10010],dis[10010];
int flag;
int main(){
int Case;
scanf("%d",&Case);
while(Case--){
memset(p,0,sizeof(p));
memset(dis,0,sizeof(dis));
sum=0;
flag=0;
int i,j,k,m,n;
int x,y,z;
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(i==j)map[i][j]=0;
else map[i][j]=inf;
for(i=1;i<=m;i++){
scanf("%d%d%d",&x,&y,&z);
map[x][y]=z;
map[y][x]=z;
}
for(i=1;i<=n;i++)
dis[i]=map[1][i];
p[1]=1;
num=1;
int MIN;
while(num<n){
MIN=inf;
for(i=1;i<=n;i++)
if(!p[i] && dis[i]<MIN){
MIN=dis[i];
j=i;
}
int ans=0;
for(i=1;i<=n;i++)
if(p[i] && map[j][i]==MIN)ans++;
if(ans>1){
flag=1;
break;
}
p[j]=1;
sum+=dis[j];
num++;
for(k=1;k<=n;k++)
if(!p[k] && dis[k]>map[j][k])
dis[k]=map[j][k];
}
if(flag)printf("Not Unique!\n");
else printf("%d\n",sum);
}
return 0;
}