SDUT-1271 面向对象程序设计上机练习九(对象指针)

面向对象程序设计上机练习九(对象指针)

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
建立对象数组,内放5个学生数据(学号是字符串类型、成绩是整型),设立max函数,用指向对象的指针作函数参数,在max函数中找出5个学生中成绩最高者,并输出其学号和成绩。
Input
输入5个学生数据。
Output
输出5个学生中成绩最高者的学号和成绩。
Example Input
01 89
02 78
03 56
04 92
05 76
Example Output
04 92
Hint
Author
zlh
#include <iostream>
#include <cstdio>
using namespace std;
class Point
{
private:
    string x;
    int y;
public:
    void Insert(string xx,int yy);
    friend void Sort(Point*a);
};
void Point::Insert(string xx,int yy)
{
    x=xx;
    y=yy;
}
void Sort(Point*a)
{
    string x;int y=-1;
    for(int i=0;i<5;i++)
    {
        if(a[i].y>y)
        {y=a[i].y;x=a[i].x;}
    }
    cout<<x<<' '<<y<<endl;
}
int main()
{
    int y;
    string x;
    Point a[5];
    for(int i=0; i<5; i++)
    {
        cin>>x>>y;
        a[i].Insert(x,y);
    }
   Sort(a);
    return 0;
}
#include <bits/stdc++.h> ///Another MF choice
using namespace std;
class A
{
private:
    string a[100];
    int b[100];
public:
    void setd()
    {
        for(int i=0; i<5; i++)
            cin>>a[i]>>b[i];
    }
    void Max()
    {
        string x;
        int y=-1;
        for(int i=0; i<5; i++)
        {
            if(y<b[i])
            {
                y=b[i];
                x=a[i];
            }
        }
        cout<<x<<' '<<y<<endl;
    }
};
int main()
{
    A p,*t;
    t=&p;
    (*t).setd();
    (*t).Max();
    return 0;
}


0
0
0
0
0
0
0
0
0
0
0
0
0


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值