Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45 59 6 13

之前没有用getchar(),一直错误,getchar()函数功能是从stdio中读字符,getchar函数getchar函数的功能是从键盘上输入一个字符。其一般形式为: getchar(); 通常把输入的字符赋予一个字符变量,构成赋值语句,使用getchar函数还应注意几个问题: 1.getchar函数只能接受单个字符,输入数字也按字符处理。输入多于一个字符时,只接收第一个字符。 2.使用本函数前必须包含文件“stdio.h”。

代码如下:

#include<stdio.h>
char a[25][25];
int m,n,sum;
void digui(int x,int y)
{
    if(a[x][y]=='#')
        return ;//退出当前的操作
    if(x<1||x>m||y<1||y>n)
        return ;
    sum++;//计数
    a[x][y]='#';//标记已经走过的地方
    digui(x+1,y);//找到起点,四个方向搜索,标记搜索过的点
    digui(x-1,y);
    digui(x,y+1);
    digui(x,y-1);
}

int main()
{
    int x,y,i,j;
    while(scanf("%d%d",&n,&m),n|m)
    {sum=0;
        for(i=1;i<=m;i++)
        {
           getchar();//接受字符
            for(j=1;j<=n;j++)
            {

                scanf("%c",&a[i][j]);
                if(a[i][j]=='@')//从开始的地方
                x=i,y=j;

            }
        }
        digui(x,y);
        printf("%d\n",sum);

    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值