J - How many integers can you find

点击打开链接


  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
  For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7




#include<cstdio>
#include<cmath>
#include<algorithm>
#define LL long long
using namespace std;
LL num[25];
LL n,m;
LL gcd(LL a,LL b)
{
	int r;
	while(b!=0)
	{
	  r=b;
	  b=a%b;
	  a=r;	
	}
	return a;
}
LL lcm(LL a,LL b)
{
	return a/gcd(a,b)*b;
}
LL solve()
{
	LL ans = 0;		
	for (LL i = 1 ; i <(1<<m) ; i++)		
	{
		LL ant = 0;		
		LL k = 1;	
		for (LL j = 0 ; j < m; j++)
		{
			if (i & (1<<j))		
			{
				ant++;
				k=lcm(k,num[j]);//因为m集合内的数不一定是质数,所以当集合内数累乘时应求其最小公倍数。
			}
		}
		if (ant & 1)		
			ans += n / k;
		else
			ans -= n / k;
	}
	return ans;
}
int main()
{
	LL i;
	while(~scanf("%lld %lld",&n,&m))
	{
		n=n-1;
	  for(i=0;i<m;i++)
	  {
	    scanf("%lld",&num[i]);
	    if(num[i]==0)   //m集合内的数可能有0,将情况排除
	      {
	      	i--;
	      	m--;
		  }
	  }
	  sort(num,num+m);
	  printf ("%lld\n",solve());
    }
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值