How many integers can you find(容斥定理)

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7

解题思路

题目意思就是给你一个数N,再给你几个这个,看看能被1~N-1中有多少个数能被整除,一看到这直接直接写结果RE(除零了),因为给的数没有说是质因数,可能有零,所以我们再奇加偶减是减的不应该是给的数相乘,而是他们的最小公倍数,因为给的数不一定是质数。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
typedef long long ll;
ll as[maxn];

ll lcm(ll a,ll b)
{
   return (a*b/__gcd(a,b));
}
int main()
{
   ll n,m;
   while(~scanf("%lld %lld",&n,&m))
   {
   	n=n-1;
   	int d=0;
   	for(int i=1;i<=m;i++)
   	{
   		int x;
   		scanf("%d",&x);
   		if(x==0) d++;
   		else
   		{
   			as[i]=x;
   		}
   	}
   	ll ans=0;
   	m=m-d;//要把零的情况减去 
   	for(ll i=1;i<(1<<m);i++)
   	{
   		ll res=1,cnt=0;
   		for(ll j=0;j<m;j++)
   		{
   			if(1&(i>>j))
   			{
   				res=lcm(res,as[j+1]);//记得最小公倍数 
   				cnt++;
   			}
   		}
   		if(cnt&1)
   		{
   			ans+=n/res;
   		}
   		else
   		{
   			ans-=n/res;
   		}
   	}
   	printf("%lld\n",ans);
   }
   
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值