POJ - 1847 Tram

Tram

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17999 Accepted: 6711

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

也不算什么难题,就是建图比较烧脑(其实感觉图论问题建图才决定一切-.-)

每一个节点有一个方向,那么就把它直接指向的方向的权值设置为0,需要转向的方向就设置为1。直接套用dijkstra求出的最短路径就代表了铁路网络需要转几次方向。

#include <iostream>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
using namespace std;
int maze[105][105];
struct node{
	int dir,val;
};
void dijkstra(int s,int e,int k)
{
	int dis[105] = {0};
	bool vis[105] = {false};
	for (int i = 1; i <= k; i++){
		dis[i] = maze[s][i];
	}
	vis[s] = true;
	for (int i = 1;i < k; i++){
		int min = inf,total = -1;
		for (int j = 1;j <= k; j++){
			if (!vis[j] && min > dis[j]){
				min = dis[j];
				total = j;
			}
		}
		vis[total] = true;
		for (int i = 1; i<= k; i++){
			if (dis[i] > dis[total] + maze[total][i]){
				dis[i] = dis[total]+maze[total][i];
			}
		}
	}
	if (dis[e] >= inf)
		cout <<"-1"<< endl;
	else
		cout << dis[e] << endl;
}
int main ()
{
	int m,n,k;
	while (~scanf ("%d%d%d",&k,&m,&n)){
		memset(maze,inf,sizeof maze);
		for (int i = 1;i <= k; i++){
			int p;
			scanf ("%d",&p);
			for (int j = 1;j <= p; j++){
				int total;
				scanf ("%d",&total);
				if (j != 1)
					maze[i][total] = 1;
				else
					maze[i][total] = 0;
			}
		}
		dijkstra(m,n,k);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值