Pick-up sticks(判断线段是否相交)

http://poj.org/problem?id=2653

Pick-up sticks
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12394 Accepted: 4673

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

题意就是按顺序输出在最上面的线(也就是它们的上面没有线压着它们的那些线)

唯一要注意的就是两个for循环里要用break,把后面不用判断的线都排除掉,不然会超时,其他就是套模板而已。。

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
int const MAXN = 100005;
struct point{
    double x, y;
    point(double x = 0, double y = 0);
};
typedef point Vector;
point::point(double x, double y){
    this->x = x;    this->y = y;
}
struct stick{
    point a, b;
}s[MAXN];
Vector operator -(const Vector &A, const Vector &B){//向量的减
    return Vector(A.x - B.x, A.y - B.y);
}
double cross(point A, point B){
    return A.x * B.y - A.y * B.x;
}
bool judge(point a1, point a2, point b1, point b2){
    double c1 = cross(a2 - a1, b1 - a1), c2 = cross(a2 - a1, b2 - a1),
           c3 = cross(b2 - b1, a1 - b1), c4 = cross(b2 - b1, a2 - b1);
    return c1 * c2 < 0 && c3 * c4 < 0;
}
int main()
{
    int n;
    while(scanf("%d", &n) && n != 0){
        for(int i = 1; i <= n; i++)
            scanf("%lf %lf %lf %lf", &s[i].a.x, &s[i].a.y, &s[i].b.x, &s[i].b.y);
        queue<int> q;
        for(int i = 1; i <= n; i++){
             for(int j = i + 1; j <= n; j++){
                if(judge(s[i].a, s[i].b, s[j].a, s[j].b))
                    break;
                if(j == n)  q.push(i);

            }
        }
        q.push(n);
        printf("Top sticks:");
        while(!q.empty()){
            int k = q.front();
            q.pop();
            printf(" %d", k);
            if(q.empty())
                printf(".\n");
            else
                printf(",");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这个问题可以用递归或回溯的方式来解决。首先将等式转换为一个字符串,例如 "1+2=3" 就可以转换为 "1+2=3#",其中 "#" 表示字符串的结束符。 然后可以定义一个函数,该函数的输入为一个字符串和两个整数 a 和 b,表示当前字符串中 a 和 b 之间的部分需要判断是否成立。函数的递归终止条件为当字符串中没有剩余的火柴棒时,判断 a+b 是否等于 c。如果等于,则返回 True,否则返回 False。 在函数中,可以使用一个循环来枚举当前字符串中 a 和 b 之间的火柴棒个数 i,然后分别计算 a 和 b 对应的数字。如果当前字符为 "+",则将 a 和 b 对应的数字相加;如果当前字符为 "=",则判断 a+b 是否等于 c。如果等于,则返回 True;否则继续递归判断接下来的字符串部分。 下面是一个简单的 Python 代码实现: ``` def is_equation_valid(equation): equation += '#' # 添加字符串结束符 def helper(s, a, b): if not s: # 火柴棒用完了,判断 a+b 是否等于 c return a + b == c for i in range(1, len(s)): if s[i] == '+': if helper(s[i+1:], a+count(s[:i]), b): return True if helper(s[i+1:], a, b+count(s[:i])): return True elif s[i] == '=': if helper(s[i+1:], a+count(s[:i]), b): return a + b == c return False def count(s): return sum([sticks[c] for c in s]) sticks = {'0': 6, '1': 2, '2': 5, '3': 5, '4': 4, '5': 5, '6': 6, '7': 3, '8': 7, '9': 6} a, b, c = [count(x) for x in equation.split('=')] return helper(equation, 0, 0) ``` 其中,sticks 字典用于将数字字符映射到对应的火柴棒个数。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值