POJ-2420-A Star not a Tree?(模拟退火求费马点)

(一)题面:

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

 

(二)题意:

给出二维平面中的n个点的坐标,找一个到所有点得距离之和最小的点,并输出最短距离,实际上也就是求费马点。

 

(三)题解:

模拟退火入门&&板子题。模拟退火不懂的可以先看看模拟退火简介

 

(四)代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
#include<ctime>
#include<algorithm>
#define eps 1e-10
#define PI acos(-1)
#define delta 0.98
#define Random T*(rand()*2-RAND_MAX)
#define Drand (long double)rand()/RAND_MAX
using namespace std;
struct Point{
    double x,y;
    Point(double _x=0,double _y=0){x=_x;y=_y;}
    long double dist(Point &p){
        return sqrt((x-p.x)*(x-p.x)+(y-p.y)*(y-p.y));
    }
}P[101],now,nxt;
long double solve(Point p,int n){
    long double res=0;
    for(int i=0;i<n;i++)
        res+=p.dist(P[i]);
    return res;
}
int main(){
    #ifdef DanDan
    freopen("in.txt","r",stdin);
    #endif // DanDan
    int n;scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%lf%lf",&P[i].x,&P[i].y);
        now.x+=P[i].x;
        now.y+=P[i].y;
    }now.x/=n;now.y/=n;
    double ans=solve(now,n),res;
    for(long double T=40001;T>eps;T*=delta){
        nxt.x=now.x+Random;
        nxt.y=now.y+Random;
        res=solve(nxt,n);
        if(ans>res)ans=res,now=nxt;
    }
    printf("%d\n",int(ans+0.5));
    return 0;
}

 

(五)总结:

新知识入门题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值