【POJ 2420】A Star not a Tree?

A Star not a Tree?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3929 Accepted: 1952

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source


模拟退火。


详细介绍模拟退火


模拟退火的步骤:

1.任意生成一个解


2.对解进行移动(随着时间的推移移动范围逐渐减小):

如果新生成的解比当前解优,直接移动;

如果没有当前的解优,那么有一定的概率移动(随着时间的推移这个概率逐渐减小)


3.移动范围减小到一定程度后程序结束


#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <ctime>
#include <cstdio>
using namespace std;
struct Point
{
	double x,y;
}a[105];
int n;
double dis(double x,double y,Point a)
{
	return sqrt((x-a.x)*(x-a.x)+(y-a.y)*(y-a.y));
}
double Getans(double x,double y)
{
	double ans=0.0;
	for (int i=1;i<=n;i++)
		ans+=dis(x,y,a[i]);
	return ans;
}
int main()
{
	//srand((unsigned)time(0));
	while (scanf("%d",&n)!=EOF)
	{
		double x=0,y=0,t=1e5,ans=1e20;
		for (int i=1;i<=n;i++)
		{
			scanf("%lf%lf",&a[i].x,&a[i].y);
			x+=a[i].x,y+=a[i].y;
		}
		x/=n,y/=n;
		ans=Getans(x,y);
		while (t>0.02)
		{
			double tx,ty;
			tx=0,ty=0;
			for (int i=1;i<=n;i++)
			{
				tx+=(a[i].x-x)/dis(x,y,a[i]);
				ty+=(a[i].y-y)/dis(x,y,a[i]);
			}
			double tmp=Getans(x+tx*t,y+ty*t);
			if (tmp<ans)
				ans=tmp,x+=tx*t,y+=ty*t;
			else if (t>(double)(rand()%100000))
				ans=tmp,x+=tx*t,y+=ty*t;
			t*=0.9;
		}
		printf("%.0f\n",ans);
	}
	return 0;
}



感悟:

1.RE是因为poj不能加srand(time(0))


2.对于模拟退火中移动方法,t的减小幅度等还需根据不同题目来定

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值