Shopping

Shopping

Description
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.

Input
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p ‘s price has increased s.

Output
Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

大佬们都用哈希表,我就平平淡淡用map吧……

#include<iostream>
#include<map>
#include<string>

using namespace std;

map<string,int>f;
string name[10005];

int main()
{
    int n,m,num;
    while(cin>>n)
    {
        f.clear();
        for(int i=0; i<n; i++)
        {
            cin>>name[i];
            f[name[i]]=0;
            if(name[i]=="memory") num=i;
        }
        cin>>m;
        while(m--)
        {
            string temp;
            int cnt=0;
            int up;
            for(int i=0; i<n; i++)
            {
                cin>>up>>temp;
                f[temp]+=up;
            }
            for(int i=0; i<n; i++)
            {
                if(f[name[i]]>f[name[num]]) cnt++;
            }
            cout<<cnt+1<<endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值