Shopping HDU - 2648

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's price after the change of everyday.

每个女孩子都喜欢购物,小T也是。她发现春节临近,很多商店都在涨价。她喜欢一个叫"memory"的商店。她希望之后,这个商店的价格排名,在每天各个商店涨价之后。

Input

One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
有多组数据,读入到文件结束。
第一行一个整数n,表示商店的数量。
接下来n行,每行一个字符串,表示商店的名称。
接下来一行一个整数m,表示天数。
接下来m部分,每部分有n行,包含一个整数s和一个字符串p,表示商店p的价格涨了s。

Output

Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.
输出“memory”商店在涨价之后的排名,如果有t个商店的价格高于它,那么它的排名就是t+1
可以认为,初始价格,每个商店都相同。

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

思路

因为看到是字符串对应数值,不同于普通的数组。我们要用map容器来创造映射。平时用的数组就是数值和数值的映射
map可以创建任何类型的映射,所以map的初始化需要两个类型
当创建好映射后,map的操作就和普通的数组一样
使用迭代器遍历map,it->second可以提取map的真值,要注意这是固定格式
然后就看有多少真值大于我们的店铺的真值
输出名次即可

AC代码

#include"bits/stdc++.h"
using namespace std;
int main(){
	map<string,int>mp;//创建map映射
	int n;
	while(cin>>n){
		string shop;
		int temp=n;
		while(temp--)cin>>shop;//只是读入名字,不进行操作
		int m;
		cin>>m;
		while(m--){
			for(int i=0;i<n;i++){
				int price;
				cin>>price>>shop;
				mp[shop]+=price;//和数组一样操作即可
			}
			int no=1;
			map<string,int>::iterator it;
			for(it=mp.begin();it!=mp.end();it++){
    			if(it->second>mp["memory"])no++;//it->second就是表示map对应的真值,固定格式
    		}
			cout<<no<<endl;
		}
		mp.clear();
	}
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值