1503 Integer Inquiry

Integer Inquiry
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5360 Accepted: 2131

Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

 

Sample Output

 

Source
East Central North America 1996

 *************************************************************************************************

*********************************************************************************************

  • Source Code
    #include<stdio.h>
    #include<string.h>
    
    int main()
    {
    	int a[200];
        char b[200];
    	int i;
    	
    	for(i=0;i<200;i++)
    		a[i]=0;
    	while(1)
    	{
    		scanf("%s",b);
    		if(strcmp(b,"0")==0)
    			break;
    		strrev(b);
    		for(i=0;b[i]!='/0';i++)
    			a[i]+=(b[i]-'0');
    	}
    	for(i=1;i<200;i++)
    	{
    		a[i]+=a[i-1]/10;
    		a[i-1]=a[i-1]%10;
    	}
       for(i=199;a[i]==0;i--);
    	for(i;i>=0;i--)
    		printf("%d",a[i]);
      printf("/n");
    		
    	return 0;
    }
    
    

     

    370370367037037036703703703670

     

    123456789012345678901234567890
    123456789012345678901234567890
    123456789012345678901234567890
    0
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值