POJ 1503 Integer Inquiry
题目链接——>点击打开链接
Integer Inquiry
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 35569 | Accepted: 13869 |
Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
Sample Output
370370367037037036703703703670
Source
Problem Idea
【题意】
题目理解:计算输入中给出的VeryLongIntegers的总和。
题目理解:计算输入中给出的VeryLongIntegers的总和。
输入输出要求,用中文复述一下:
输入将包含至多100行文本,其中每个文本都包含一个VeryLongInteger。
每个VeryLongInteger的长度不超过100个字符,并且只包含数字(非VeryLongInteger将为负数)。
最后的输入行本身会在一行上包含一个零。
您的程序应该输出输入中给出的VeryLongIntegers的总和。
您的程序应该输出输入中给出的VeryLongIntegers的总和。
【注意】
1、 BigInteger sum初始化一定要在while循环外初始化,不然会输出错误
Source Code
import java.util.*;
import java.math.BigInteger;
public class Main {
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
BigInteger sum=BigInteger.valueOf(0);
//BigInteger sum=new BigInteger("0",10);//str形式初始化,初值为0,10进制数
while (in.hasNext()){
BigInteger x=in.nextBigInteger();
if(x.equals(new BigInteger("0"))){
//System.out.println(sum);
break;
}
sum=sum.add(x);
}
System.out.println(sum);
}
}