PAT甲级1168 Prime Day

文章介绍了一个编程问题,要求判断给定日期(如20190523)中所有以该数字结尾的子串是否为质数。使用C++编写代码,通过substr函数去除首字符并检查剩余部分是否为质数。
摘要由CSDN通过智能技术生成

wbfg.JPG

The above picture is from Sina Weibo, showing May 23rd, 2019 as a very cool "Prime Day". That is, not only that the corresponding number of the date 20190523 is a prime, but all its sub-strings ended at the last digit 3 are prime numbers.

Now your job is to tell if a given date is a Prime Day.

Input Specification:

Each input file contains one test case. For each case, a date between January 1st, 0001 and December 31st, 9999 is given, in the format yyyymmdd.

Output Specification:

For each given date, output in the decreasing order of the length of the substrings, each occupies a line. In each line, print the string first, followed by a space, then Yes if it is a prime number, or No if not. If this date is a Prime Day, print in the last line All Prime!.

Sample Input 1:

20190523

Sample Output 1:

20190523 Yes
0190523 Yes
190523 Yes
90523 Yes
0523 Yes
523 Yes
23 Yes
3 Yes
All Prime!

Sample Input 2:

20191231

Sample Output 2:

20191231 Yes
0191231 Yes
191231 Yes
91231 No
1231 Yes
231 No
31 Yes
1 No

 分析:编写prime函数判断是否是质数。通过s=s.substr(1,s.length()),每次去掉第一个数字;如果是质数,则输出此数字和Yes,如果不是质数,则输出此数字和No,并且将flag置false。

#include <bits/stdc++.h>
using namespace std;
bool prime (int n){
	if ( n < 2)return false ;
	for (int i = 2;i<=sqrt(n);i++){
		if ( n %i == 0)return false;
	}
	return true ;
}
int main (){
	string s;
	bool flag = true ;
	cin>>s;
	for (int i = 0;i< 8;i++){
		cout << s<<" ";
		if ( prime (stoi(s))){
			cout<<"Yes"<<endl;
		}
		else {
			cout <<"No"<<endl;
			flag = false ;
		}
		s=s.substr(1,s.length());
	}
	if (flag == true )cout <<"All Prime!";
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值