PAT甲级1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 分析:首先编写prime函数判断是否是素数;如果输入n<0直接退出循环;随后判断n是否是素数,如果不是素数直接输出No,否则建立a数组用于存每个进制运算的余数,是倒着存的,len用于存取数组的长度,随后用n=n*d+a[i]累乘算出翻转之后的n,随后判断新的n是否是素数,如果是输出Yes,如果不是输出No。

#include <bits/stdc++.h>
using namespace std;
bool prime (int n){
	if (n<2)return false ;
	for (int i= 2;i<=sqrt(n);i++){
		if (n % i==0)return false ;
	}
	return true ;
}
int main (){
	int n,d;
	while (cin >> n){
		if (n<0)break;
		cin >>d;
		if (prime (n)==false){
			cout <<"No"<<endl;
		}
		else {
			int a[31]={0},len = 0;
			while (n){
				a[len]=n%d;
				len++;
				n/=d;
			}
			for (int i= 0;i<len;i++){
				n = n * d + a[i];
			}
			if (prime(n)){
				cout << "Yes"<<endl;
			}
			else {
				cout << "No"<<endl;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值